jdk和weblogic的配置

jdk和weblogic的配置

选择 WebLogic 9.2 的原因

①WebLogic 8 支持的是 J2EE 1.3,也就是 Servlet 2.3 规范。若在 MyEclipse 中建立 Web Project 时选择了 J2EE 1.4[default],在部署的时候就会出现异常,提示部署描述符 web.xml 是畸形的,也就是未通过 DTD 检验。因为 J2EE 1.4 使用的是 Servlet 2.4 规范,这直接体现在 web.xml 部署描述符的头部引用中。这就是有些朋友遇到的,部署在 Tomcat 和 JBoss 中能够运行的 JSP 程序,部署到 WebLogic 8 就无法运行的原因之

一。解决这个问题,需要将 WebLogic 升级到 9.2 版本;或者使用 J2EE 1.3。

Servlet 2.3 规范生成的 web.xml 头部:

jdk和weblogic的配置

jdk和weblogic的配置

jdk和weblogic的配置

jdk和weblogic的配置

jdk和weblogic的配置

<?xml version="1.0" encoding="UTF-8"

jdk和weblogic的配置

?>

<!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"

"http://www.wendangwang.com/dtd/web-app_2_3.dtd">

jdk和weblogic的配置

<web-app>

jdk和weblogic的配置

...

</web-app>

jdk和weblogic的配置

Servlet 2.4 规范生成的 web.xml

jdk和weblogic的配置

头部:

jdk和weblogic的配置

jdk和weblogic的配置

<?xml version="1.0" encoding="UTF-8"

jdk和weblogic的配置

?>

<web-app version="2.4" xmlns="http://www.wendangwang.com/xml/ns/j2ee"

xmlns:xsi=http://www.wendangwang.com/2001/XMLSchema-instance

xsi:schemaLocation="http://www.wendangwang.com/xml/ns/j2ee

http://www.wendangwang.com/xml/ns/j2ee/web-app_2_4.xsd">

...

</web-app>

②若在上一个问题选择了 J2EE 1.3 进行开发后,在部署时会出现另外的异常,提示“Unsupported

major.minor version 49.0”—— 又是版本问题,这次是由于 JDK 版本不支持造成的。WebLogic 8 不支持 JDK 1.5,由 JDK 1.5 编译的程序无法部署到只支持 JDK 1.4 的服务器上运行。解决的办法也有两个:用 JDK 1.4 重新编译;或者换用支持 JDK 1.5 的服务器,也就是升级到 WebLogic 9.2。

配置 WebLogic 9.2

安装 WebLogic 比较容易,在这里就不再累述了,大家可以参阅相关文档。现在着重讲一下 WebLogic 的配置,因为后面在配置 MyEclipse 时将用到这里的配置信息。

①运行开始 -> 程序 -> BEA Products -> Tools -> Configuration Wizard。

②选择 Create a new WebLogic domain,Next。

③在 Select Domain Source 界面保持默认,Next。

④在 User name 处输入 user,两个 password 都输入 12345678(密码要求 8 位),Next。

⑤ 在 Configure Server Start Mode and JDK 界面中保持默认,即 JDK 选择的是“Sun SDK 1.5.0_04 @

Word文档免费下载Word文档免费下载:jdk和weblogic的配置 (共4页,当前第1页)

jdk和weblogic的配置相关文档

最新文档

返回顶部