短线猎枪源码

短线猎枪源码

参数:P5:49,1,300}
牛熊界:MA(CLOSE,P5),LINETHICK2,colorWHITE;
KS:=(((CLOSE - EMA(CLOSE,13)) / EMA(CLOSE,13)) * (0 - 100));
趋势线:=EMA(((KS / 10) + EMA(CLOSE,10)),3);
AA:= - 100 * (趋势线 - CLOSE) / 趋势线;
AC:=(EMA(AA,5) );
STICKLINE(((((CLOSE >= OPEN) ) AND (AA >= 0)) AND (AA >= AC)),OPEN,CLOSE,7.8,1),colorFF;
STICKLINE(((((OPEN > CLOSE) ) AND (AA >= 0)) AND (AA >= AC)),CLOSE,OPEN,7.8,0),colorFF;
STICKLINE(((((CLOSE >= OPEN) ) AND (AA >= 0)) AND (AA >= AC)),CLOSE,HIGH,0.5,1),colorFF;
STICKLINE(((((CLOSE >= OPEN) ) AND (AA >= 0)) AND (AA >= AC)),OPEN,LOW,0.5,1),colorFF;
STICKLINE(((((OPEN > CLOSE) ) AND (AA >= 0)) AND (AA >= AC)),CLOSE,LOW,0.5,0),colorFF;
STICKLINE(((((OPEN > CLOSE) ) AND (AA >= 0)) AND (AA >= AC)),OPEN,HIGH,0.5,0),colorFF;
STICKLINE(((((CLOSE >= OPEN) ) AND (AA >= 0)) AND (AA < AC)),OPEN,CLOSE,7.8,1),colorFF00FF;
STICKLINE(((((OPEN > CLOSE)) AND (AA >= 0)) AND (AA < AC)),CLOSE,OPEN,7.8,0),colorFF00FF;
STICKLINE(((((CLOSE >= OPEN) ) AND (AA >= 0)) AND (AA < AC)),CLOSE,HIGH,0.5,1),colorFF00FF;
STICKLINE(((((CLOSE >= OPEN) ) AND (AA >= 0)) AND (AA < AC)),OPEN,LOW,0.5,1),colorFF00FF;
STICKLINE(((((OPEN > CLOSE) ) AND (AA >= 0)) AND (AA < AC)),CLOSE,LOW,0.5,0),colorFF00FF;
STICKLINE(((((OPEN > CLOSE) ) AND (AA >= 0)) AND (AA < AC)),OPEN,HIGH,0.5,0),colorFF00FF;
STICKLINE((((CLOSE >= OPEN) ) AND (AA < 0)),OPEN,CLOSE,7.8,1),colorD38784;
STICKLINE((((OPEN > CLOSE)) AND (AA < 0)),CLOSE,OPEN,7.8,0),colorD38784;
STICKLINE((((CLOSE >= OPEN) ) AND (AA < 0)),CLOSE,HIGH,0.5,1),colorD38784;
STICKLINE((((CLOSE >= OPEN) ) AND (AA < 0)),OPEN,LOW,0.5,1),colorD38784;
STICKLINE((((OPEN > CLOSE) ) AND (AA < 0)),CLOSE,LOW,0.5,0),colorD38784;
STICKLINE((((OPEN > CLOSE) ) AND (AA < 0)),OPEN,HIGH,0.5,0),colorD38784;
AG:=SUM((VOL / FINANCE(7)),1);
STICKLINE(((((((CLOSE >= OPEN) AND (DATATYPE < 7)) ) AND (AG >= 8)) AND (AG < 15)) AND (AA >= 0)),OPEN,(OPEN * 1.008),10,0),colorFF;
STICKLINE(((((((OPEN > CLOSE) AND (DATATYPE < 7)) ) AND (AG >= 8)) AND (AG < 15)) AND (AA >= 0)),(OPEN * 1.008),OPEN,10,0),colorFF;
STICKLINE(((((((CLOSE >= OPEN) AND (DATATYPE < 7)) ) AND (AG >= 8)) AND (AG < 15)) AND (AA < 0)),OPEN,(OPEN * 0.998),10,0),colorFF;
STICKLINE(((((((OPEN > CLOSE) AND (DATATYPE < 7)) ) AND (AG >= 8)) AND (AG < 15)) AND (AA < 0)),(OPEN * 0.998),OPEN,10,0),colorFF;
STICKLINE((((((CLOSE >= OPEN) AND (DATATYPE < 7)) ) AND (AG >= 15)) AND (AA >= 0)),OPEN,(OPEN * 1.008),15,0),colorFFFFFF; STICKLINE((((((OPEN > CLOSE) AND (DATATYPE < 7)) ) AND (AG >= 15)) AND (AA >= 0)),(OPEN * 1.008),OPEN,15,0),colorFFFFFF;
STICKLINE((((((CLOSE >= OPEN) AND (DATATYPE < 7)) ) AND (AG >= 15)) AND (AA < 0)),OPEN,(OPEN * 0.998),15,0),colorFFFFFF; STICKLINE((((((OPEN > CLOSE) AND (DATATYPE < 7)) ) AND (AG >= 15)) AND (AA < 0)),(OPEN * 0.998),OPEN,15,0),colorFFFFFF;
SSL:=EMA(CLOSE,3);


MMV:=EMA(((SLOPE(CLOSE,22) * 20) + CLOSE),55); MM:=(IF(((DATATYPE > 5) AND (DATATYPE < 9)),MA(MMV,1),IF((DATATYPE = 5),MA(MMV,4),IF((DATAT

短线猎枪源码相关文档

最新文档

返回顶部